Setting up gradle project with spring boot starter

Hi,
I’m just trying to setup a new camunda 8 project with spring boot starter and had a dependency issue.
If I use v8.4.0 io.camunda.spring:spring-boot-starter-camunda:8.4.0 then all seems happy but anything later, for example io.camunda.spring:spring-boot-starter-camunda:8.5.3, then it fails to find io.camunda:identity-spring-boot-autoconfigure:8.5.1.
We tested this in maven and it all works happily. After investigating it looks like the spring-boot-starter-camunda refers to a parent pom

  <parent>
    <groupId>io.camunda.spring</groupId>
    <artifactId>spring-client-root</artifactId>
    <version>8.5.3</version>
  </parent>

which in turn defines the dependent repos

  <repositories>
    <repository>
      <id>zeebe-snapshots</id>
      <name>Zeebe Snapshot Repository</name>
      <url>https://artifacts.camunda.com/artifactory/zeebe-io-snapshots/</url>
      <releases>
        <enabled>false</enabled>
      </releases>
      <snapshots>
        <enabled>true</enabled>
      </snapshots>
    </repository>
    <repository>
      <id>connectors-snapshots</id>
      <name>Connectors Snapshot Repository</name>
      <url>https://artifacts.camunda.com/artifactory/connectors-snapshots/</url>
      <releases>
        <enabled>false</enabled>
      </releases>
      <snapshots>
        <enabled>true</enabled>
      </snapshots>
    </repository>
    <repository>
      <id>identity</id>
      <name>Identity Repository</name>
      <url>https://artifacts.camunda.com/artifactory/camunda-identity</url>
      <snapshots>
        <enabled>false</enabled>
      </snapshots>
    </repository>
  </repositories>

This structure is not supported by gradle. This could be gotten around by adding these repos to our own build.gradle, but we use a restricted repository with everything going through AWS codeartifact.
Are these dependencies going to be published to maven central like all the other artifacts, otherwise it means we have to republish each missing dependency to our repo?

Thanks,
Matt