Should point to a running camunda engine

I have recently deployed my microservice which has camunda engine rest dependency on a Kubernetes cluster, pod is running fine, and I am able to login via the camunda portal (https://xyz.com/camunda/app/welcome/default/#!/login). I am able to get the group of a user, using the camunda-engine rest api https://xyz.com/engine-rest/identity/groups?userId=admin.

Somehow when i try to deploy bpmn using Camunda Modeler, and enter the endpoint which looks like this, (https://xyz.com/engine-rest/deployment/create) I get to see “Camunda Engine should be running at this endpoint”. I am able to get the users inside a group using a rest api, then why not deploy using Camunda Modeler?

image

Please help me

You should just put https://…/engine-rest and nothing else, so remove “/deployment/create” from the url you have and try again

But that doesn’t really work, it should deployment/create, that is what really works. I found the issue, it’s because I am using HTTPS here, in postman, I am able to call engine-rest APIs because I have disabled SSL there so that kinda works. but for the Camunda modeler, there isn’t an option to disable it.

Camunda Modeller can works throught https. It uses Chrome browser settings while connecting to rest-endpoint
If ssl certificate is self signed, then you should place rootCA certificate to Trusted certificate list in your browser.

@MaximMonin can you explain your solution please. I have the same problem. How can I access to rootCA certificate?

Check certificate generation script and nginx config in this project