Simple FEEL function

Just getting started

I think I am reading that Camunda only supports FEEL within a Decision Table?

I want to explore FEEL operators and functions. As the simplest possible starting point, I would like a decision that simply adds two input integers a+b=c

Can someone help me with the attached? Does Camunda support this approach?

BPMNDiagram1.bpmn (2.5 KB)

DMNExample1.dmn (2.0 KB)

Hi @ghdunn.

FEEL expressions can be used in decision tables and in decision literal expressions.

What are the problems that you see?

Best regards,

Hi @Philipp_Ossler - thanks for responding.

I am really trying to spin up the simplest possible example in order to test the concept and then develop from there. I just couldn’t find a relevant example in the docs.

I have a decision © that has two integer inputs: a & b. So c=a+b
I call that decision into a process that has one task. I want to input values for a and b and get the result c which is their sum.

The models i have attached try to do that, but I was confused that when the task required inputs, they could only be defined as strings, not as integers. When i did get this working it just seemed to concatenate the two values.

Make sense?


Yes, if the variables are strings then they are concatenated.

In the decision, you can access process variables by its name. You don’t need to pass the variables in the BPMN using input parameters. All variables are accessible.

I am sorry @Philipp_Ossler
What you say makes sense but I don’t know how to execute it

This is what i have…but i can’t see how i set values to the variable

Any thoughts?

You can pass the variables when creating the workflow instance.

Thanks @Philipp_Ossler

But if i click on Start Process Instance it just tells me it is running.

If i then go to the cockpit I don’t see any decisions

Hi there,

I have exactly the same issue.

The problem becomes obvious when trying to simulate the example provided by @ghdunn in the DMN simulator (Camunda DMN-Simulator): No value is passed to variable c. I also tried hard coding/assiging any value to c in the simulator but nothing worked so far.

@Philipp_Ossler: do you have any advice here?

Thank you

It seems that this is a UI bug in the DMN simulator. The simulation is built with decision tables in mind.
It only shows input fields for decision table inputs.

The decision is evaluated correctly but it is not shown in the UI. If you open the web console of your browser then you can inspect the decision result.