Simple monitor doesn't show any of deployed processes

we have deployed zeebe cluster v.8.0.5 with helm chart to Kubernetes and simple-monitor v2.4.1. Zeebe brokers use hazelcast exporter in docker image Package zeebe-with-hazelcast-exporter · GitHub and there is a hazelcast cluster v5.1.3 deployed as well.
Everything looks fine, there are no any errors regarding the hazelcast connection in brokers or in simple-monitor, we can see all the hz clients in the hazelcast mancenter including zeebe brokers and simple-monitor.
The problem is that we cannot see any deployed processes in the simple-monitor UI, in spite of the fact that it’s deployed and working fine.
Where can the issue be? What else can we check except the logs file of the brokers and simple-monitor itself?

Hey @cyberpank,
that is an interesting behaviour! :thinking:

The Zeebe Simple Monitor currently lacks of a maintainer. Due to this it could have happened that there is some incompatibility with newer Camunda Platform 8 versions and the Monitor.

If you cannot spot any errors in the logs, I can only advise you to try running it with some older versions of Zeebe.
I have tried Simple Monitor early this year - back then it worked fine…
Let me know if you figure something out. Otherwise, I will try to investigate something in the upcoming weeks. :+1:


Hafflgav thanks for the answer. Actually, when I run the simple-monitor and zeebe without external hazelcast it works as expected and we can see the workflows in UI, this behaviour reproduces when the hazelcast exporter uses the external server. But I can not figure out how to use for example N zeebe brokers with internal hazelcast on each node and simple-monitor as it requires only one connection string for the hazelcast, moreover, every node should share the information to the monitor and looks like it is impossible in this case.

Puh… I understand. :thinking:
Generally speaking a Zeebe cluster containing multiple broker should somehow only use on Hazelcast exporter.
In that sense, have you tried running a “one broker” cluster with the external Hazelcast?

A lot of commits to the repository have been made by @Philipp_Ossler - Maybe he knows more about this. (Thanks for chiming in, in advance!)

In that sense, have you tried running a “one broker” cluster with the external Hazelcast?

No, but I’m going to find out how it will work, ok.

1 Like