[Solved]Configuring camunda with sql server

I am trying to configure sql server as my camunda database.
I am using apache tomcat prepackaged .zip file and starting application using start_camunda.bat

I have successfully created the database with the name Camunda using the sql scripts now I have all the tables.

and I have just update my server.xml file like this

<Resource name="jdbc/ProcessEngine"
              minIdle="5" />

but it is not working


Hi @leo_9223,

have you added the JDBC driver (sqljdbc4.jar) to the folder $DISTRIBUTION_PATH\server\apache-tomcat-8.0.24\lib?

If that doesn’t help, maybe try setting the url to

Hope this is useful to you.


Thank you for your reply.

Actually, I am using VMWare windows server 2012
I have configured ldap for user authentication previously which is working fine. I want ldap for user authentication and sql server for process data.

The steps you have stated I have performed but still not working :frowning:

camunda opens the welcome page but when I go to login page browser says unable to reach.

and there are no logs :frowning:

Hi @leo_9223,

can you check that the process engine name in the URL of the login page is the same as the process engine name that you have configured in your bpm-platform.xml?

If that doesn’t help, please open your browser development tools (typically with F12) and check the Network tab when opening the login page.


Hi @leo_9223,

Could you please check for the logs at $DISTRIBUTION_PATH\server\apache-tomcat-8.0.xx\logs\catalina.out or $DISTRIBUTION_PATH\server\apache-tomcat-8.0.xx\logs\localhost.log and post the error message (stacktrace) here.


I am using all the instructions in this page https://docs.camunda.org/manual/7.6/installation/full/tomcat/manual/

when I run start-camunda.bat it opens welcome page in browser but when I go to cockpit or admin instead of going to login page browser says ERR_CONNECTION_REFUSED :frowning:

very important it is not creating any logs :frowning: logs folder is empty

2nd option:
On the other hand I have deployed standalone web app .war file on my apache tomcat and then configured ldap and sql server using instructions on this page https://docs.camunda.org/manual/7.6/installation/standalone-webapplication/
and it is configured but its only web application I have to use rest api of camunda for this I have deployed rest api .war file to my tomcat using instructions here https://docs.camunda.org/manual/7.6/installation/full/tomcat/manual/#rest-api and when I access using the url localhost:8080/engine-rest/engine it gives 404 error.

Now I need to configure sql server using prepackaged .zip file
I need to run rest api using .war file considering second option

any help would be highly appreciable.

Hi @leo_9223,

could you please attach tomcat logs?
If there are no log files, you should make sure that all java processes are dead before starting as well as any process which can block port 8080, such as skype for instance.


when I used to execute engine script in sql server it executes successfully but throw this error

"Warning! The maximum key length is 900 bytes. The index ‘ACT_IDX_JOB_HANDLER’ has maximum length of 8510 bytes. For some combination of large values, the insert/update operation will fail."

Hi @leo_9223,

this is a known issue (see CAM-7442 ) and has been fixed with the upcoming 7.7.0 release. Until then, we recommend to not create the index.

Does this help you?


Thank you so much guys. I really appreciate your replies.

Problem Solved

Problem was not in the configuration at all
I have just used configuration details on this page, configured and runt it successfully LDAP + Sql Server 2014

What was the problem then?
my JRE_HOME environment variable was pointing to the wrong directory sigh !!! took my two days it happens it happens

which version of sqljdbc.jar did you use for connecting to Sql Server 2014 ?

I used sqljdbc4-2.0.jar and it worked.

Hi, Could you help me?
I have got same your problem. I start camunda-bpm-tomcat-7.14.0 and I see http://localhost:8080/camunda-welcome/index.html then Tomcat is closed and When I click on Tasklist or Cockpit or Admin or … I see error “localhost refused to connect.”
I will be grateful If you help me.