SSL Connection is not working

I’m able to start and access Camunda Optimize from my windows server but I cannot access Optimize from “outside”.

I want to use SSL, so e.g.

I already modified the “environment-config.yaml” but where can I specify the path to the SSL certificate? How does Optimize know how to use SSL?

Thanks for helping!!

Hi @svenr,

it’s configured on the container level: Configuration |

Leave the http port configuration empty to disable unencrypted access.

Hope this helps, Ingo

1 Like

Hi @Ingo_Richtsmeier,
do you mean in the following?

Because I only see a few parameters from your url there. Or where can I find the settings?


you can add required settings there like “container.keystore.location”, “container.keystore.password”

1 Like

Thanks @Alex_Voloshyn

I think that worked because I didn’t get any errors.
But I still cannot access the URL from “outside”.

The host is just my domain, e.g. “”, isn’t it?

I do not know for sure that it should be your domain because you use a Docker container to run it. Have you tried to set it to localhost?

With localhost it is just working on the windows server…

Do you have DNS configured to route “” to your local IP address?

I think so, yes…
I’m also able to access the Camunda Platform from “outside” via (SSL)