Starting a process with a timer event cause a ClassNotFoundException org.camunda.spin.Spin.S

Useing Spin i had the same error of this topic: Javascript with Spin results in ClassNotFoundException org.camunda.spin.Spin.S.

I solved it exaclty as “Axel_W” suggested, and it worked just fine, until i tried to run my process with a “Timer Start Event” with a cycle every 20 seconds.

If i start the process from an API call, it works just fine, without errors, but if i wait for the automatic start caused by the job the classNotFoundException pop out again, exactly the same error that i had before.

Does someone know how is this possible?

So no one have ever encountered this problem?

I tried to search and fix the issue, but the only other thing that i have discovered is that the real problem isn’t the timer, but the async running.

If i do not use the timer but i check the script task as “async before” i get the same ClassNotFoundException.

I hope that this can help someone else understanding the root of the problem…