The Camunda REST API cannot be accessed

After downloading the demo of, I cannot access the Camunda REST API documentation. The version is 7.17.0. The configuration is as follows:

Who can tell me what the path to the Camunda REST API is. I tried http://localhost:8080/engine-rest/, and http://localhost:8080/swaggerui/ didn’t work

Hi @DeepDreamerLSC

Do you see anything at http://localhost:8080/ ?


Hello @jwulf
I can see the Camunda BPM platform at http://localhost:8080/,I think it’s normal.

Hi @DeepDreamerLSC

What exact URL did you try? What was the exception?

If I call http://localhost:8080/engine-rest I get a 404.

With for example http://localhost:8080/engine-rest/deployment I get a result

Hi @pme123
If I call http://localhost:8080/engine-rest,I get a 404 too,
but call http://localhost:8080/engine-rest/deployment,I get this exception.
I basically throw this exception when I call other url.
But I also introduced the REST API dependency.


Hi @DeepDreamerLSC

Ok I downloaded the starter and tested it - works as expected (I am on a Mac).

This is the curl Call I used:

curl --location --request GET 'http://localhost:8080/engine-rest/deployment'

Which returns

Hi @pme123
I’m glad to see that I got the same result, which seems to mean I can call the REST API’s interface normally, so why not access the API documentation?

@DeepDreamerLSC @pme123
I guess you are trying to see swagger docs/ open api specification.
That is not enabled by default in spring boot projects. You have to make following changes and then it will work.

  1. Add following dependencies in your pom.xml
  1. Add following repository to your pom.xml because by default these dependencies are not available on maven central.
    <name>Camunda Platform Maven Repository</name>

Make sure you rebuild the project so that dependencies are downloaded.
The URL for swaggerui is as below .



Hi @ad_sahota
Thank you very much, it’s a usable way and it’s really the result I wanted