Timer stuck.


I am very new to Camunda so forgive me if I don’t manage to provide all the details from the get-go.

So we have been running a camunda container with some bpms, We were creating the processes using the API and since we wanted to send the creation request and straight away return to the api we implement a 2s delay at the very start. It used to work correctly, but now suddenly it started getting stuck in the delay.

Anyone got any ideas or suggestion as to what I could try to resolve this issue?
I did try messing with the configuration as was suggested in other similar topics, but it quite hard without rebuilding our container definition ( Its running in Kubernetes so shutting down camunda actually recreates the container )

Thanks for the help!

hello my friend!

This may be something related to job acquisition / job executor in Camunda.

Try changing the waitTimeInMillis property in your XML file to 2000 or 1000.

It might help to resolve the issue.

Below is a link to help you better understand and configure your executor job.

I hope this helps!

William Robert Alves


Hi @arnyziukas,

In conjunction with William’s statement, the maxWait parameter should be adjusted to a lower value (2 seconds) to ensure that the waiting time does not exceed 2 seconds.

Below is a simplified explanation:

In case there are less jobs in ACT_RU_JOB table than (maxJobsPerAcquisition) , the job acquisition waits for (waitTimeInMillis) before submitting jobs to the queue. If this keeps happening over and over again, the wait time will increase rapidly by multiplying it with the waitIncreaseFactor , but it won’t exceed the maximum waiting time (maxWait).