Token simulation plugin probblem

In Camunda Modeler I try to use the token simulator but I get:

Tried to access di from the businessObject. The di is available through the diagram element only.

I am on:

Camunda Modeler system information

  • Version: 5.9.0
  • Operating System: Mac OS 10.15.7
  • Plugins: bpmn-js Token Simulation
  • Execution Platform: BPMN - Camunda Platform 7


Nobody had this problem, all are happy, except me. :joy:

Hello my friend!

could you send us a print of your BPMN?

This is the BPMN:
diagram_2.bpmn (10.8 KB)


Good morning my friend!

I don’t know if this is your problem in the token simulator… but come on!

You have an “inclusive gateway” in your process, it serves to follow only one path or more than one path if necessary.

notice that you have tokens entering through several sides of the inclusive gateway, BUT ALWAYS ONLY ONE OUT.

1st Point to check - In your process, you have only ONE OUTPUT from this gateway, so I don’t think it’s necessary to use it. It seems correct to me to use EXCLUSIVE GATEWAY in this case.

2nd Point to check - Exchange this INCLUSIVE GATEWAY for an EXCLUSIVE GATEWAY, and see if it will work.


I remember that a while ago I tried to use it, and it didn’t work with any of the gateways… but I don’t remember which one.

If I helped in any way, or your case was solved with this, please leave your like and mark it as “solved” / “Solution” please.

I hope this helps.

William Robert Alves

The issue has nothing to do with the design of the flow.

Look another simple flow and the Token plugin give the same error:

This happen only on MacOs as I mentioned in the first post. On Windows all it’s ok. This is the direction of the investigation.

Thanks for your help,

uuuurgh… this is bad bro! :frowning:

Make sure there isn’t a more current version for your plugin, it seems to be a compatibility issue.

Or try reinstalling modeler or redownloading the plugin.

William Robert Alves

Tried, reinstalled Camunda Modeler, downloaded the plugin again. But that didn’t solve the problem.
On MacOS I am now testing the workflow with Postman.

I think someone at Camunda must know there is a problem with the plugin on MacOS and maybe fix it.