Token simulator plugin fails in Desktop Modeler ("Not a registered action")

I’ve got the latest Desktop Modeler (5.15.0) and the latest Token Simulation Plugin.

The plugin loads but doesn’t work.

I get this error:

toggleTokenSimulation is not a registered action
    at a (webpack://camundanode_modules/diagram-js/lib/features/editor-actions/EditorActions.js:266:9)
    at error (webpack://camundanode_modules/diagram-js/lib/features/editor-actions/EditorActions.js:175:10)
    at trigger (webpack://camunda-modeler-client/src/app/tabs/cloud-bpmn/BpmnEditor.js:704:40)
    at triggerAction (webpack://camunda-modeler-client/src/app/tabs/MultiSheetTab.js:269:18)
    at triggerAction (webpack://camunda-modeler-client/src/app/tabs/EditorTab.js:36:33)
    at triggerAction (webpack://camunda-modeler-client/src/app/App.js:1881:15)
    at fn (webpack://camunda-modeler-client/src/app/App.js:2388:19)
    at file:///C:/Users/t/Downloads/camunda-modeler-5.15.0-win-x64/resources/app.asar/public/bundle.js:2:3451066
    at exec (webpack://camunda-modeler-client/src/app/AppParent.js:76:11)
    at triggerAction (webpack://camunda-modeler-client/src/app/AppParent.js:350:61) [ error ]
This error may be the result of a plug-in compatibility issue. [ info ]

Has anyone else come across this? I can’t find any references to it. Maybe my google-fu is weak. Thakns.

Hi @tlj

Let me look into this, i’ll see if i can replicate the problem

So, using the latest version of the modeler and the latest version of token simulation i was able to run it without any issues. Is there something else that could be causing the problem

I guess so. I’ve tried various installs/removes with no joy. I’ll try it on a different machine in the next day or two. Thanks for checking - that’s encouraging anyway!

Can you give some details about your OS and if it still works on older versions of the modeler?

It’s only an issue in the latest version for me. I tested these versions (it’s a joy there’s no installer :slight_smile: )

  • 5.15 FAIL
  • 5.14 OK
  • 5.13 OK
  • 5.10 OK
  • 5.4 OK
  • 5.0 OK

I’m using a fully updated Win 10 Pro (22H2).

I’ll just get going with 5.14, but I’ll be happy to help further if you can’t reproduce it.

1 Like

There are some folks from the modeler team looking into this. I’ll let you know if there’s any update

1 Like

Hi @Niall

Actually it seems more like a plugins problem. I have the same error with other plugins while using Camunda Modeler v5.15.0


1 Like

Hi @tlj and @qube

A new version of the modeler has been released which fixes this problem :slight_smile:
You can download and install it now


Validated. :partying_face:
Thanks @Niall for the update!