Unable to create user using email id as username

Unable to create user account using email id as username in Camunda Version 9. This was working in Version 8. Please let us know if there is any setting to be done in any configuration file in Camunda framework. Please help its urgent and many user have got hampered with this.

Welcome to the Community

Can you clarify the version number. There is no Camunda 9 or 8.
Also explain your setup, explain what code is running and explain the error your getting and when posting that information be sure to check the style guide. so that it’s easier to understand your response.

We aer using camunda BPM - v7.10.0
and the issue appears in Camunda 7+ above version
I am getting error while creating new user using email address. PFA the screen shot.

Do you perhaps mean 7.13 ?

Can you look in the logs for a more detailed error?

Are you running Camunda on an application server?

Do you perhaps mean 7.13 ? yes

log.txt (8.9 KB)

Are you running Camunda on an application server? Yes I am running on DexCenter 13.0.13 application server

Did you follow this migration guide?

Hi @nagraj,

I think “@” is not allowed in a user id due to the default whilelist: https://docs.camunda.org/manual/7.13/user-guide/process-engine/identity-service/#custom-whitelist-for-user-group-and-tenant-ids

You have to configure the userResourceWhitelistPattern according to your needs.

Hope this helps, Ingo

But in which XML file do we need to configure userResourceWhitelistPattern. I tryied to make changes in proccess.xml file but that didn’t work.
Please let me know the file name and location of that file.

Hi @nagraj,

How do you run Camunda BPM?

Tomcat container managed engine, Wildfly container managed engine, Spring boot, Camunda Run, Embedded Engine in a war file?

Each installation has it’s own configuration file.

Cheers, Ingo

I run Camunda BPM using Wildfy container manged engine

Hi @nagraj,

here is the way to go: https://docs.camunda.org/manual/7.13/reference/deployment-descriptors/descriptors/bpm-platform-xml/.

Check the content of the box: In Wildlfly it’s standalone.xml where you have to configure the whitelist pattern.

Hope this helps, Ingo.

Can you please help me with some example of configured standalone.xml with userResourceWhitelistPattern as I am unable to find were to put - <
property name=“userResourceWhitelistPattern” value="[a-zA-Z0-9-]+" />
inside standalone.xml file.

I tried to make changes in standalone.xml file under attirubute
< security-realm name=“ManagementRealm”>
< authentication>
< local default-user="$local" skip-group-loading=“true”/>
< properties path=“mgmt-users.properties” relative-to=“jboss.server.config.dir”/>
< /authentication>
< authorization map-groups-to-roles=“false”>
< properties path=“mgmt-groups.properties” relative-to=“jboss.server.config.dir”/>
< property name=“userResourceWhitelistPattern” value="[a-zA-Z0-9-]+" />
< /authorization>
< /security-realm>

But this didn’t work.

Hi @nagraj,

it has to be part of the camunda subsystem.

This worked for me:

<property name="userResourceWhitelistPattern">

And here is the complete CamundaBPM configuration:

        <subsystem xmlns="urn:org.camunda.bpm.jboss:1.1">
                <process-engine name="default" default="true">
                        <property name="jobExecutorAcquisitionName">
                        <property name="isAutoSchemaUpdate">
                        <property name="authorizationEnabled">
                        <property name="jobExecutorDeploymentAware">
                        <property name="historyCleanupBatchWindowStartTime">
                        <property name="userResourceWhitelistPattern">
                    <job-acquisition name="default">
                            <property name="lockTimeInMillis">
                            <property name="waitTimeInMillis">
                            <property name="maxJobsPerAcquisition">

Hope this helps, Ingo

That solution not working to me . Is there any configuration need to be done on database side.
I tryied making changes in standalone-full.xml