Unable to submit a task

Hi ,
I created a loan-workflow using camunda , which uses basic"embedded" HTML pages to fill data , and I am unable to complete a user-task .
When i try to click on "Complete " , it shows a sign , indicating you can’t submit this .

Hi @Arsh_Baghel,

I think you are not the task is not assign to you, right?
You should assign it first and then you are going to be able to complete it.

Best regards,

Hi @yana.vasileva,

The task is assigned to me only .

I have 59 other tasks at this task-definition , that show this :

But this one task shows this :

One more thing, do you have any fields which are marked as required? This could be the problem also

1 Like

Hi @yana.vasileva ,
I checked the code for any missed " required " tags .

This link contains the code for the page :

Hi @Arsh_Baghel,

Sorry for the delay.
Is it possible to share the process itself + forms so I could try it locally?

Best regards,

Hi @yana.vasileva ,

I can see certain changes in the HTML of the buttons:

  1. cam2
    <'button class=“btn btn-primary ng-binding” type=“submit” ng-click=“complete()” ng-disabled=“disableCompleteButton()” disabled=“disabled”>
  1. cam1

<'button class=“btn btn-primary ng-binding” type=“submit” ng-click=“complete()” ng-disabled=“disableCompleteButton()”>

What this function “disableCompleteButton()” actually does ???

Hi @Arsh_Baghel,

If you have not resolved the issue already, please try to remove this attribute:

Best regards,

I did this … and it worked … :slight_smile:

But , is this a bug/issue .?

Why this happens ??

I ask again :: What this function “disableCompleteButton()” actually does and when is this called???

PS : This has happened to 2 more tasks .


By adding this attribute to the button, you are marking the button as disabled.
Did you add this attribute on purpose?

Best regards,

@yana.vasileva ,
No — i didn’t add any button/script in the html .

This contains the code for the HTML-page :: https://pastebin.com/raw/x35GDBjF

Hi again,

We need to test this locally so please upload your process file and forms.

Best regards,

Hi @Arsh_Baghel and @Yana ,

I have the same problem.
I didn’t set the disabled attribute to the complete button, but it’s there.
So I created another embedded task and there the complete button isn’t disabled.
Therefore I’m really interested in what the “disableCompleteButton()” does and why
the complete button gets disabled.



has the task been claimed by a user?
If not, that is what would prevent the complete button form being enabled.

Hi @Niall,

yes I assigned both tasks to a user via the Camunda Modeler

So, is the user that is viewing the task in tasklist the same user that is assigned to the task?

yes, thats correct

Can you upload your model?

process.bpmn (6.6 KB)

There’s my simple model and i added a screenshots of the two task. i can only complete the “old Wizard” task