Why Camunda can't delete a process instance?

Hey guys! :vulcan_salute:
As a beginner in Camunda Platform, I trying to understand some key features in platform, and I found some instance process who seem to running indefinitely.

So I try to delete this running instance throuth the REST API using Postman, but it doesn’t work. I try delete using Camunda Cockpit too, but the same error is returned. It seems Camunda can’t find the instance to delete, but the instance is found in GET requests and it still visible in Camunda Cockpit.

Here is the error message from the Camunda Cockpit, and below the same error using the REST API with Postman sending a DELETE request:

But still in Postman, if I switch the request method to GET, the same process instance is found as well.

Does anyone can send me a tip or already seen this behavior? :sweat_smile:

which version of Camunda Platform are you using? It might be just a wrong error message propagation, hiding another issue, as reported in https://jira.camunda.com/browse/CAM-13830 (fixed in 7.14.2 - see the last comment).

Hi Eileen!
I have the 7.11 version, so I’ll try using the latest version, and will come back here with some news as soon as possible.