Why swaggerui not available

in doc: https:/docs.camunda.org/manual/latest/installation/camunda-bpm-run/
it wrote: Access Swagger UI via http://localhost:8080/swaggerui/ to try out the REST API.

I can access the app and rest, but i can’t access swaggerui,
it shows:

Whitelabel Error Page

This application has no explicit mapping for /error, so you are seeing this as a fallback.
Fri Apr 09 15:02:28 CST 2021
There was an unexpected error (type=Not Found, status=404).

how to resolve it?

Are you sure you’re running Camunda Platform Run 7.15 ? any other distro of version won’t have the swagger ui deployed

thank you, solved.
I’m running 7.14 download from mainpage.

The official release of 7.15 is not until next week, the download page will be updated by then :slight_smile:


I am using 7.15.0-ee but still getting the same error while accessing swaggerui.

I am using springboot starter for my application

implementation (“org.camunda.bpm.springboot:camunda-bpm-spring-boot-starter-webapp-ee:7.15.0-ee”)
implementation (“org.camunda.bpm.springboot:camunda-bpm-spring-boot-starter-rest:7.15.0-ee”)

Do we need any configuration for this ?


It’s only available out of the box for our Camunda Platform Run distribution.

Hi @Niall , thanks for creating a great tool.
I’m currently using Camunda Platform 7.15 with Spring Boot Starter. However, whenever access localhost:8080/swaggerui, it shows the error page only.
What wrong did I make?

Spring-Boot: (v2.4.3)
Camunda Platform: (v7.15.0)
Camunda Platform Spring Boot Starter: (v7.15.0)


Hi @Quang_Thai_Duy
Welcome to the forum

this topic has been marked as resolved, generally it’s better to create a new topic if you want to continue the discussion :slight_smile:

But the answer to your question is that we only provide the swagger ui out of the box for the Camunda Run distro. For spring boot you’ll need to add it yourself.
Luckily @Jean_Robert_Alves has actually spent some time getting this working so you can take a look at what he has been able to build.