Camunda forms not visible v7.15

I followed the tutorial Camunda Platform Tutorial: Adding Forms and Starting Up A Spring Boot Project - YouTube

but the camunda forms are not visible. I think it’s because the tutorial uses older version but then the documentation is also outdated and I couldn’t find what to put in the Form Ref field

Second point
The documentation for 7.16 for this page is outdated
User Task Forms |

The document says there will be Form Key field, but there is no such field. Instead there are three field to populate - Type, Form Ref and Binding

I tried below but didn’t work
Trial 1: Type - Camunda form, Form Ref - "camunda-forms:/forms/.form
Trial 2: Type - Camunda form, Form Ref - "/forms/.form

1 Like

Hi @cprasad111

You’re right, the UI has changed a bit since there - i’ve created a video explaining

Hello Niall,
I used id of the form to populate Form Ref field as directed in the updated video, but still the same problem

I see another post about updating processes.xml, but where is this file?

Is my understanding correct. For spring boot project, I just need modeler to create bmpn and form file and then run the java project. No need to have Camunda-bpm-run separately running?

resource/static/forms/preparefordeparture.form (id:departure)

Got file is empty while uploading bpmn file, so zipped the resources folder, changed extension to .txt and uploaded for your review

resources.txt (6.1 KB)

In the localhost Camunda UI, under More → Deployments → SpringAutoDeployment, I only see bpmn file, I don’t see the two forms which are present in the resources/static/forms. Looks like the forms are not getting picked up. Some config should be done somewhere, I suppose

** Latest Update **
Updated yaml as below, and now the More → Deployments → SpringAutoDeployment list bpmn and forms as well. I can click the form and see the fields/form. But still the form is not visible under Task List :cry:

- classpath*:/.bpmn
- classpath
- classpath
- classpath
- classpath

I’m only using @SpringBootApplication annotation and nothing else

Hi @cprasad111,

with this setup, the formRefon the user task has to contain the Idof the form from the form editor:

Unfortunately we don’t have any matching documentation right now available

Hope this helps, Ingo

I tried the same and shared the resources zip file containing both bpmn and form file. Unfortunately, it is not working. I’ll leave it now and wait when the documentation is updated and then try again

Even I am facing the same issue. Tried everyting. Still getting form failure.