Camunda RestAPI GET request problems

Hello everyone,

I created a schema to test camunda, but I can’t send 2 get requests to the server.

Error:
Failed to invoke connector, received the following error: Apache HTTP client does not support GET requests with content.

Can you help me with the subject

Can you give more details about what exactly your setup is and what exactly you’re doing to get the error you’ve mentioned?

Hi,

In the application, I made a get request and added an if condition.

I’m trying to send a second get request based on the response but I’m getting Apache HTTP client error.

start => first get request => select item => if(selectItem==true) => second get request => ERROR

Can you show the request your making and how it’s configured

Hi Niall thank for your help,

My get requests are like this

And both requests work without any problems when called from postman?

Yes it works in postman without any problems

and it’s its the trades call that’s creating the problem?

Yes i am having a problem with calling trade.

When I add another endpoint, the problem is the same, I always get an error on the 2nd call.

Alrighty, i’ll take some time to look into this.

Thanks for your help.

Please let me know if there is an improvement.

Best regards

Can you export and send me your BPMN file

Yes of course

BPMN File:
microservice-orchestration-tutorial.bpmn (11.5 KB)

@suleymanbyzt Can you try by passing pairSymbol in query param. Let me know if that works.

image

Hi,

I also tried this but got the same error. @Arjun1007

Hi @Niall
Thank you for your support. I solved the problem by creating a new project.

1 Like

@suleymanbyzt could you pls share how it was resolved?