Cannot login into Camunda with correct credentials: Error Wrong Credentials!

Dear all,

I have been struggling with camunda. In particular, with opening Task forms. However, at the Moment I am not able to log into camunda at all. I have no idea what the error is in my application. I have attached the relevant files.

catalina.2017-07-25.log (23.4 KB)
localhost.2017-07-25.log (5.0 KB)
pom.xml (2.5 KB)


Hi @nnkala,

Does the user have rights to the app (tasklist/cockpit/admin) you want to login?


Yes I was using the username demo. All Login credentials have worked before.


please try to hard reload the page, on chrome CTRL + SHIFT + R should work.
If this does not work please reset your cache.


Hey I tried all of that both on Chrome and IE. Ist still giving the same error

Hi @nnkala,

did you change anything in Camunda admin? Changed some authorizations or group memberships? Does the login work with a fresh Camunda installation?

Best regards

@nnkala, you mention here that you had the wrong credentials. Is this issue also resolved now?


wrong credentials for mysql database.

I have the similar problem with Camunda hosted on Azure Web app.

I can not enter to cockpit camunda and i get error
" Login Failed : Wrong credentials, locked user or missing access rights to application"
REST endpoints working fine with this credentials.

This is occuring since time when I increased number of instance of application from 1 to 2.
This is my docker-compose:

version: '3.3'
     image: camunda/camunda-bpm-platform:tomcat-7.15.0
       - "8080:8080"
       - ${WEBAPP_STORAGE_HOME}/WEB-INF/web.xml:/camunda/webapps/engine-rest/WEB-INF/web.xml
     restart: always

And in Azure envrionment variables I have configured all variables required to connect to pgsl.

When I change number of instance to 1, entering to cockpit working fine.
Doesn’t work for instance more than one.
Did i miss something? Some additional configuration is required?

Any help. please


Hi @Lukasz_Jedrusik,

if you run in a cluster behind a load balancer, you have to use sticky sessions in the load balancer: Architecture Overview |

Here is an alternative for the cloud approach: Camunda BPM - Session Management in Cloud Environments - Camunda

Hope this helps, Ingo

Thank You Ingo,

In the meantime I arrived to the solution, and you are right in this case sticky sessions is the key!
For someone who will be looking for information how to turn on sticky sessions in azure web app services, this is in configuration web app and is called “ARR affinity”, please look to link below


1 Like

Hi @Lukasz_Jedrusik,

thank you for providing more insights into required Azure configuration!