Can't deploy process diagram image

I need to get the process diagram as png from External Service Task. When i tried to get it via REST Api as it is described in the documentation i get 204 (empty) response. I checked the process definition calling /rest/engine/default/process-definition/key/{mykey} and in the returned JSON there’s a property called “diagram” which is null.


“diagram”: null,
“suspended”: false,
“tenantId”: null,
“versionTag”: null,
“historyTimeToLive”: null

I exported the diagram as png from Modeler and saved it in the same directory with the .bpmn file and with the same name (but with .png extension instead of .bpmn) as mentioned here. Still no luck. The process definition’s diagram is still “null”.

I tried to do it (export the diagram as png and save it in the folder where the .bpmn files are) with the Standalone Web Application Distribution, and again using camunda as embedded bpmn engine within spring boot application using camunda-bpm-spring-boot-starter-webapp. In thestandalone web application i deploy the process from the Modeler and export the diagram image in the same folder. In the spring boot application, i store the diagram image in the resources folder where the bpmn files are.

What am i doing wrong?


SOLVED! I just had to deploy the process diagram manually using the REST API rest/engine/default/deployment/create and append the file as “diagram” parameter in the POST request.

Here’s the request in case anyone is wondering how to do it.


Thank you :slight_smile:

1 Like