Form failure, no error message (SOLVED)

Hi,
I’m new on Camunda and start to practice with camunda forms from Get Started section on camunda documentations site.
The problem was found when I started the Process and try to access the form.
The form was not shown or rendered and only display Form failure:

How can I troubleshoot this (e.g. where to check the app logs?, etc)
Or it might some steps I missed.

I use camunda 7.16 and modeler 4.11.1.

Regards,
[bayu]

UPDATE - SOLVED:
Form reference on Form’s users task should be the same with Form ID (Form file).

formref

At first I wrote the form filename with extension (as shown on doc / video).

Thank you,

2 Likes

Thanks for posting the solution @bwidyasanyata :slight_smile:

@bwidyasanyata I didn’t understand
Form reference on Form’s users task should be the same with Form ID (Form file).

In above statement what is Form ID? Can you explain clearly? I also struck at this point. Please explain.

@bwidyasanyata
Is the Form Id same as name of form created?

Hi @rakesh_189,

the form Id is given in the from modeler: Camunda forms not visible v7.16 - #6 by Ingo_Richtsmeier

Hope this helps, Ingo

I tried entering form id in form ref, but it’s still showing Form failure in Camunda Tasklist.

How to solve issue @Ingo_Richtsmeier

Let me clarify on both screenshot below, since actually this topic I post were I couldn’t post more than one image attachment (new member) :slight_smile:

Below is the form reference of a model (.bpmn file)

and here is the form id in form modeler (.form file)

Both should have the same value, in this case: paymentForm2.

Thank you,

@bwidyasanyata

I followed your instructions, same as you mentioned , but not working again show the message “Form Failure” (Camunda Platform 7.17 && Modeler 5.0.0)
Could you give a solution ?

I have the same problem. I have a springboot app and I use the Camunda Modeler 5.0.0. My .form file is in the static/forms folder. When I enter the form id in the Form reference in the user task the error occurs…

What am I doing wrong?

Hi @Tee0Paw,

the *.form files didn’t get automatically deployed. You have to move them into the src/main/resources folder and add a valid processes.xml file in src/main/resources/META-INF

<process-archive>
  <properties>
    <property name="isDeleteUponUndeploy">false</property>
    <property name="isScanForProcessDefinitions">true</property>
    <property name="additionalResourceSuffixes">form</property>
  </properties>
</process-archive>

As an alternative you can deploy the form from the modeler.

Hope that helps, Ingo

1 Like

Hi @Ingo_Richtsmeier,

thanks for reply!
I followed the youtube tutorial with SpringBoot. In this tutorial there is no META-INF folder.
So i have to add the folder, right?

Hi @Tee0Paw,

not necessarily. There is also an option to run the Spring Boot Application without the @EnableProcessApplication annotation. In this case you can configure the deployment resources in the application.yml file with .deployment-resource-pattern: Process Engine Configuration | docs.camunda.org

Hope this helps, Ingo