FreeMarker Script Engine not found in wildfly docker image

I had some issues with FreeMarker and tried to get an answer here. After some posts, I decided to create a new topic, cause it looks like I have got an issue with the process engine and not the modeler :slight_smile:

Steps I did:

  1. I downloaded and started camunda/camunda-bpm-platform:wildfly-7.12.0-SNAPSHOT like described here
  2. After that I deployed and started this bpmn which starts a script task to list all installed script engines: list_all_found_scripts.bpmn (3.2 KB)
  3. Check the log files

My script does not list FreeMarker:

04:58:29,212 INFO [] (Controller Boot Thread) WFLYSRV0025: WildFly Full 16.0.0.Final (WildFly Core 8.0.0.Final) started in 13035ms - Started 755 of 949 services (350 services are lazy, passive or on-demand)
04:59:58,881 INFO [stdout] (default task-1) Oracle Nashorn
04:59:58,882 INFO [stdout] (default task-1) 1.8.0_212
04:59:58,883 INFO [stdout] (default task-1) ECMAScript
04:59:58,885 INFO [stdout] (default task-1) ECMA - 262 Edition 5.1
04:59:58,886 INFO [stdout] (default task-1) [js]
04:59:58,887 INFO [stdout] (default task-1) [application/javascript, application/ecmascript, text/javascript, text/ecmascript]
04:59:58,888 INFO [stdout] (default task-1) [nashorn, Nashorn, js, JS, JavaScript, javascript, ECMAScript, ecmascript]

If I do the same steps with the tomcat docker image, it lists also freemarker as engine. I double checked the module folders like described in the documentation. Also, I am able to use groovy and freemarker as Script type and define variables like ${testVar}, but I am not able to us FreeMarker inline in a javascript (like in the provided script task).

Does anyone know, how I can configure the docker wildfly to be able to load the freemarker engine in a javascript task? I need this behavior cause I store a json as clob and this json might contain some freemarker scripts (which I have to replace).

Best Regards

@menski cc

@Alex.Ph I would recommend you open a issue here:

Ok I will create an issue.
Meanwhile I solved this issue by creating a (pre)BpmnParseListener. Within this listener, I hook into the userTask creation and run my FreeMarker logic there.