How to activate HTTPS

Hello there,

I tried to enable HTTPS as in this tutorial, as it is also mentioned in the thread Activating HTTPS on Camunda Spring-Boot. But it seems, that here is a different there is another error here…

I have already deleted the SecurityConfig, because the Camunda Spring Boot Starter already contains a WebSecurityConfigurerAdapter. At the moment I can’t see the login page (not reachable):

private Connector getHttpConnector() {
        var connector = new Connector(TomcatServletWebServerFactory.DEFAULT_PROTOCOL);
        connector.setScheme("http");
        connector.setPort(8081); //not 8080, 
//because it says otherwise "Application failed to start. Port 8080 was already in use."
        connector.setSecure(false);
        connector.setRedirectPort(8443);
        return connector;
    }

Tomcat initialized two ports: 8080 (http) 8081 (http)


I have already searched further, but unfortunately do not find the reason why it does not work and since HTTPS or SSL is probably not unimportant for many, I wanted to take up the issue again to hopefully find a solution :slight_smile:

Hello again,

it had worked in the following! (only with the self-generated key see: Alias name [keyname] does not identify a key entry …)

It is not quite sure what the reason was, but the following two things were in any case not insignificant:

  • by the insertion of a SecurityConfig it has probably screwed up the start up of the server
  • in the application.yaml the following was missing… :
server:
  ssl:
    key-store: classpath:keyStoreName.p12
    key-store-password: password
    key-store-type: pkcs12
    key-alias: keyAliasName
    key-password: password
  port: 8443

Further report:
I have managed that it starts with our company’s key. However it says it is no save connection, that is why the https in the address line is crossed out.
Does someone has similiar problems? Is it possibly related to the key(-store)-password? Do you have your .jks-file in the ressources folder as well?

In addition the address change to https(crossed out)//localhost/camunda/app/welcome/default/#!/login. Is it normal that the port disappears?