Increasing size of "text" datatype in output parmeter


I am using http-connector in Camunda Modeller to hit a REST URL and should get a very long response in the output parameter. But I am getting error as below:

### Error updating database. Cause: org.h2.jdbc.JdbcSQLException: Value too long for column “TEXT_ VARCHAR(4000)”

So, what datatype should be used to store such a long response???

Please help


1 Like

Depends on the database you are using, but since it appears you are using an H2 database you should consider a LOB field type.

The error you are getting suggests you re trying to save the response into a process variable as a text string. If this is the case, try saving it as a binary, it will automatically be saved into the Activiti ACT_GE_BYTEARRAY table.

how can we change the data type from “text” in Camunda modeller…
Only 4 options are available:
Type , Script , List , Map…


Ahh yes, you will need to do this in a service task, you wont be able to get the level of control you need from the Modeler.

You could consider script such that you can process the result using some script such as groovy etc. In addition, you could then set a process variable yourself and store it as a serialized object or byteArray. By default, strings are stored in the text column with a max size of 4000 characters. ByteArrays are stored as large object types…