Whitelabel Error Page "This application has no explicit mapping for /error, so you are seeing this as a fallback."

Hi, all

I have a small detail in my process, I already have workgroups and user permissions to carry out the tasks.

I was doing tests and I found the error: Whitelabel Error Page

This error appears when I click on “Link instance view” (This error appears when I use my created users, if I use “demo” this error is not generated and it directs me to cockpit)

But the truth is that my created users do not want them to see Cockpit, only I want them to see and manage Tasklist (Currently my users only see and work with Tasklist, this is correct)

What I don’t understand is that I clicked on “Link to instance view”, my created users try to access the cockpit to see the diagram, which is not at all interesting for me to see the diagram in the cockpit because all users already have permissions to view the diagram in the tasklist under the “diagram” tab.

I tried to remove the Id so that it does not appear in Tasklist from the process modeling but it tells me that it is necessary to have the Id.

For now I am not interested in having or opening the cockpit with any user created, clarified in “Camunda Administration” I do not have any permissions configured to see Cockpit because I am not interested in the cockpit for now.

Look for something similar or similar in the Forum but I did not find anything, please if someone knows how to achieve this I would greatly appreciate the help.

@hassang Hi! How are you?

You know how to solve the error, I understand that my process tries to access the Cockpit but since I do not have any permission to access the Cockpit, the error is generated. but the truth is I don’t want it to open the cockpit, how can I disable “Link view to instance”?

Hi @MarioH ,

Try adding below element style to user-styles.css located in app/tasklist/styles/

a.instance-link.ng-scope {
	display: none;

Hi @hassang
Thanks for answering me.

create the directory and add the css file to that directory but nothing happened.

Hi @MarioH

Have a look at below post

And please note that this should be applied to tasklist app

Hi, @hassang

Guide me with the league that you shared with me, I thank you very much for your help.

Thanks a lot! :pray: :pray: :pray: for your help.

Best regards.

Hi again @hassang

Again bothering, sorry.

I was reviewing and I found another detail as a user who only interests me to see Tasklist, in the upper right there are the options of

  • Welcome
  • Admin
  • Cockpit

The Welcome option has no problem having it active, but the Admin and Cockpit options if there is a problem because I can log in to Admin and I see information that I should not see, as well as in the Cockpit part I see information that I should not see.

You can deactivate the option of Admin and Cockpit, if so, please help me with a guide.

Hi @MarioH,

It seems that all users have been given access to all camunda apps. (* value has been used as Resource ID instead of using tasklist value)

Usually regular users should be granted access to only tasklist app

Please have a look at below docs

Hi @hassang
Thank you so much for answerme.

It is correct what you mentioned had established with all the permissions (*), modify now they only have permissions to the Tasklist, but beyond this I wanted to know how to disable the Admin and Cockpit option in the list but I did not know how, the solution is correct Because users, even if they try to access the Cockpit or the Admin, will generate a permission error for now, so I’m going to handle it.


For now the solution was to modify the permissions maybe in the future if I would like to disable the list and leave with a single option.

Thank you for your very helpful comments.


Hi @MarioH,

Once user is logged in to tasklist “as an example” & he has only access to tasklist app then this list of apps wouldn’t be available at all.

But if login screen shows up and user is not logged in then all apps would be listed as user is not authenticated yet “user is unknown”.

Hi @hassang

What you mention is correct and it really works like this in my workflow.

Thank you for your comments.

1 Like